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Thales does not and shall not warrant that this product will be resistant to all possible attacks and 
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current security standards in force on the date of their design, security mechanisms' resistance 
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PREFACE 

This document describes how to install and configure the SafeNet Agent for Remote Desktop Gateway. 

Customer Release Notes 

The Customer Release Notes (CRN) document provides important information about this release that is 

not included in other customer documentation. It is strongly recommended that you read the CRN to fully 

understand the capabilities, limitations, and known issues for this release. 

Audience 

This document is intended for personnel responsible for maintaining your organization's security 

infrastructure. This includes SafeNet users and security officers, key manager administrators, and network 

administrators. It is assumed that the users of this document are proficient with security concepts. 

All products manufactured and distributed by Thales Group are designed to be installed, operated, and 

maintained by personnel who have the knowledge, training, and qualifications required to safely perform 

the tasks assigned to them. The information, processes, and procedures contained in this document are 

intended for use by trained and qualified personnel only. 

Document Conventions 

This section describes the conventions used in this document. 

Command Syntax and Typeface Conventions 

This document uses the following conventions for command syntax descriptions, and to highlight elements 

of the user interface. 

 

Convention Description 

bold The bold attribute is used to indicate the following: 

 Command-line commands and options (Type dir /p.) 

 Button names (Click Save As.) 

 Check box and radio button names (Select the Print Duplex check box.) 

 Window titles (On the Protect Document window, click Yes.) 

 Field names (User Name: Enter the name of the user.) 

 Menu names (On the File menu, click Save.) (Click Menu > Go To > 

Folders.) 
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 User input (In the Date box, type April 1.) 

italic The italic attribute is used for emphasis or to indicate a related document. (See the 
Installation Guide for more information.) 

Double quote marks Double quote marks enclose references to other sections within the document. 

For example: Refer to “Error! Reference source not found.” on page Error! 

Bookmark not defined.. 

<variable> In command descriptions, angle brackets represent variables. You must substitute 
a value for command line arguments that are enclosed in angle brackets. 

[ optional ] 

[ <optional> ] 

 

[ a | b | c ] 

[<a> | <b> | <c>] 

Square brackets enclose optional keywords or <variables> in a command line 
description. Optionally enter the keyword or <variable> that is enclosed in square 
brackets, if it is necessary or desirable to complete the task. 

Square brackets enclose optional alternate keywords or variables in a command 
line description. Choose one command line argument enclosed within the braces, 
if desired. Choices are separated by vertical (OR) bars. 

{ a | b | c } 

{ <a> | <b> | <c> } 

Braces enclose required alternate keywords or <variables> in a command line 
description. You must choose one command line argument enclosed within the 
braces. Choices are separated by vertical (OR) bars. 

Notifications and Alerts 

Notifications and alerts are used to highlight important information or alert you to the potential for data loss 
or personal injury.  

Tips 

Tips are used to highlight information that helps to complete a task more efficiently. 

TIP: This is some information that will allow you to complete your task more efficiently. 

Notes 

Notes are used to highlight important or helpful information. 

NOTE: Take note. Contains important or helpful information. 

Cautions 

Cautions are used to alert you to important information that may help prevent unexpected results or data 

loss. 

CAUTION!   Exercise caution. Contains important information that may help prevent 

unexpected results or data loss. 
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Warnings 

Warnings are used to alert you to the potential for catastrophic data loss or personal injury. 

**WARNING**   Be extremely careful and obey all safety and security measures. In 

this situation you might do something that could result in catastrophic data loss 

or personal injury. 

Support Contacts 

If you encounter a problem while installing, registering, or operating this product, please refer to the 

documentation before contacting support. If you cannot resolve the issue, contact your supplier or Thales 

Customer Support. 

Thales Customer Support operates 24 hours a day, 7 days a week. Your level of access to this service is 

governed by the support plan arrangements made between Thales and your organization. Please consult 

this support plan for further information about your entitlements, including the hours when telephone 

support is available to you. 

Customer Support Portal 

The Customer Support Portal, at https://supportportal.thalesgroup.com, is where you can find solutions for 

most common problems. The Customer Support Portal is a comprehensive, fully searchable database of 

support resources, including software and firmware downloads, release notes listing known problems and 

workarounds, a knowledge base, FAQs, product documentation, technical notes, and more. You can also 

use the portal to create and manage support cases. 

NOTE:  You require an account to access the Customer Support Portal. To create a 

new account, go to the portal and click the REGISTER link. 

Telephone Support 

The support portal also lists telephone numbers for voice contact (Contact Us). 

Email Support 

You can also contact technical support by email at technical.support.DIS@thalesgroup.com. 

 

https://supportportal.thalesgroup.com/
https://supportportal.thalesgroup.com/
https://supportportal.thalesgroup.com/
https://supportportal.thalesgroup.com/csm?id=kb_article_view&sys_kb_id=42fb71b4db1be200fe0aff3dbf96199f&sysparm_article=KB0013367
mailto:technical.support.DIS@thalesgroup.com
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CHAPTER 1: Introduction 

Microsoft Remote Desktop Gateway 

A gateway is any computer that connects two networks that use different network protocols. A gateway 

reformats information from one network so that it is compatible with the other network. 

The Microsoft Remote Desktop Gateway (RD Gateway) server is a type of gateway that enables 

authorized users to connect to remote computers on a corporate network from any computer with an 

Internet connection. RD Gateway uses the Remote Desktop Protocol (RDP) along with the HTTPS 

protocol to help create a more secure, encrypted connection. 

The RD Gateway server enables remote desktop connections to a corporate network without having to set 

up virtual private network (VPN) connections. 

SafeNet Agent for Remote Desktop Gateway 

The SafeNet Agent for RD Gateway is a solution to enable strong, Two-Factor Authentication (2FA) on 

users who wish to access any protected RD resource behind a Remote Desktop Gateway. 

NOTE: The SafeNet Agent for RD Gateway version 1.0 is not supported in high 

availability Remote Desktop Services configuration. 

The SafeNet Agent for RD Gateway is built on top of Microsoft Pluggable Authentication and Authorization 

(PAA) framework in combination with an integrated approach to provide uniform user login experience on 

the Microsoft Remote Desktop Web Portal. The Remote Desktop Gateway Agent comprises of the 

following four components: 

1. PAA Plugin: This is built on top of Microsoft PAA framework, and sits and runs on the server which 

is configured as a Remote Desktop Gateway. 

2. SafeNet RD Gateway Monitor service: This service monitors the connections established 

between the client machine and Session Hosts via RD Gateway, and disconnects any session that 

is invalid. 

3. Remote Desktop Web Update: Remote Desktop Web Access (RD Web Access), formerly 

Terminal Services Web Access (TS Web Access), enables users to access Remote Desktop 

Connections. 

RD Web Access includes Remote Desktop Web Connection, which enables users to connect 
remotely to the desktop of any computer where they have Remote Desktop access. In order to 
support strong authentication at RD Gateway, some updates have been incorporated in the RD 
Web. This part of the solution includes custom login page module, default page module, and inbuilt 
security modules that together with the other solution components enable strong authentication of 
the user at RD Gateway. 
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4. ActiveX for SafeNet Agent: A custom Active X component will handle the direct invocation of 

RDP session from within the Internet Explorer. 

The Pluggable Authentication and Authorization (PAA) framework for RD Gateway provided by 

Microsoft allows custom authentication and authorization routines to be used with RD Gateway. 

This can provide custom two-factor authentication and works seamlessly with Remote Desktop 

Web Access (RD Web Access) or RDP file resource launching. 

Agent Features  

Following are the features of the SafeNet Agent for RD Gateway: 

 Resource Access Duration: The user is allowed access to a remote resource only for a specific 

duration, which is set by the administrator. 

 One-time Usage of RDP File: Once the RDP file is used to access a remote resource, that RDP file 

cannot be used again unless the administrator permits. 

 Binding an RDP File to an IP Address: The RDP file can be accessed only from the machine where 

the RDP file was downloaded. If the RDP file is copied to another machine then the user's session will 

be forcefully disconnected. 

 Binding a User to an RDP File: The remote resource can be accessed only from the user login using 

which the RDP file was downloaded. If any other user tries to access the remote resource, the session 

will be forcefully disconnected. 

 Support of Native RAP: The SafeNet Agent for RD Gateway supports native Microsoft authorization. 

 Direct Access Prevention: The SafeNet Agent for RD Gateway restricts access to users who do not 

come through RD Web. That is, if the user provides the gateway host directly on the remote desktop 

connection, the connection is denied. 

 Application Support: The SafeNet Agent for RDGateway does not support Microsoft Remote 

Applications and some functionalities may not work. 

System Requirements 
This guide is applicable to the following: 

Operating Systems  Windows Server 2012 R2 (64-bit) 

 Windows Server 2016 (64-bit) 

 Windows Server 2019 (64-bit) 

Architecture 64-bit 

Web Servers  IIS 8.5 

 IIS 10 
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Operating System and Web 
Browsers for ActiveX (Client 
Machine) 

Operating System: 

 Windows 10 

Web Browsers: 

 Internet Explorer 11 (supported till June 15, 2022) 

 Microsoft Edge*  

* Since, Microsoft will retire Internet Explorer 11 on June 15, 2022, we 

recommend using Microsoft Edge with Internet Explorer mode. For more 

details, see Enable IE mode in Edge browser section.  

Applicability 

The information in this document applies to the following: 

 SafeNet Trusted Access (earlier, SAS Cloud) — The SafeNet’s cloud-based authentication service. 

 SafeNet Authentication Service - Service Provider Edition (SAS SPE) — The on-premises, server 

version targeted at service providers interested in hosting SAS in their data center(s). 

 SafeNet Authentication Service - Private Cloud Edition (SAS PCE) — The on-premises, server 

version targeted at organizations interested in hosting SAS in their private cloud environment.  

Prerequisites 

 Ensure that users are able to access the remote resource via RD Web access prior to deploying the 

agent. 

 Ensure that the SafeNet Agent for RD Web is installed and configured on the machine which hosts RD 

Web. 

 Administrative rights are required for installation and configuration of the SafeNet Agent for RD 

Gateway. 

 The RD Services (TermService) should not be running on the remote desktop gateway machine unless 

the operator needs to remotely manage it. 

 The remote machine (session host) that needs to be accessed should have the remote desktop 

services running. Also, it should be accessible from the remote desktop gateway, and should be on the 

same domain as the remote desktop gateway. 

 Ensure that the RD Gateway service (tsgateway) is running, and the mode is set to Automatic. 

 General purpose SHA1/SHA256 certificate (for RDP file digital signing) and SHA256 certificate (for 

gateway access token signing) must exist in both the RD Web and RD Gateway machines. 

 .NET framework 4.0 (or above) must exist on both the RD Web and RD Gateway machines. 

 Ensure that the RDG_CAP_AllUsers policy is enabled. 

 Ensure that the user has the ‘log on as a service’ permission before using the Service Control (SC) 

command. 
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When you configure a service to run under a specific account via Service Properties, Windows 

automatically grants the account the ‘log on as a service’ permission. Before using the SC command 

(sc.exe) to create the Windows Service (via installer), the administrator has to grant the user the ‘log 

on as a service’ permission. This setting determines which user accounts can register a process as a 

service. Running a process as a service avoids the need for human intervention. To configure a user 

account to have ‘log on as a service’ permission, follow the steps: 

Note: The ‘log on as a service’ permission applies only to the local computer and must be granted in 

the Local Security Policy of the computer. 

1. Login to the computer with administrative privileges. 

2. Open the administrative tools by selecting Start > Control Panel > System and Security > 

Administrative Tools. 

3. Click Local Security Policy from the list of file names. The Local Security Policy dialog box 

opens. 

4. Expand Local Policies by clicking its icon in the left navigation pane. The constituent files list 

in the right pane. 

5. Double-click User Rights Assignment from the list. 

6. Locate Log on as a service, right-click its icon and select Properties. The Log on as a 

service Properties dialog box opens. 

7. Click Add User or Group… to add a new user(s). 

8. Search the user(s) using Select Users, Computers, Service Accounts, or Groups dialog 

box, and click OK. You can search for multiple users by separating each user name with a 

semicolon. 

Note: Ensure that the user(s) you have added (using the above process) is not listed in the Deny 

log on as a service policy in the Local Security Policy. 

 For the agent installer to run successfully, the Active Directory for Windows PowerShell feature 

must be enabled on the Windows Server.  



 
Introduction 

 
 

SafeNet Agent for Remote Desktop Gateway v2.0.4: Installation and Configuration Guide 
007-000361-001, Rev. E, May 2022, Copyright © 2022 Thales Group. All rights reserved. 

13 

 

 

Enable the feature by following the steps:  

1. Open Server Manager. 

2. Click Add roles and features. 

3. Navigate to Features tab.  

4. Navigate to Remote Server Administration Tools > Role Administration Tools > AD DS 

and AD LDS Tools.  

5. Select the Active Directory module for Windows PowerShell checkbox, and click Next. 

6. Select the Restart the destination server automatically if required checkbox, and install the 

feature.  
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CHAPTER 2: Installation 

Installing the Agent 

You need to install three components of the SafeNet Agent for RD Gateway—RD Gateway Plugins, RD 

Gateway Monitor, and RD Web. The RD Gateway Plugins and RD Gateway Monitor components of the 

agent are to be installed on the computer where you have set up RD Gateway. Similarly, the RD Web 

component of the agent is to be installed on the computer where you have set up RD Web. For installing 

all the components, you have only one installer. 

NOTE: Installer will always be in the English language, irrespective of the language of 

the operating system. 

 

1. Run the Safenet Agent for Microsoft RDGateway installer. 

If you have logged into the system as an administrator or if you are a member of the Domain Admin 
group, the installation process will run successfully. Otherwise, a window will appear requiring you to 
provide administrator credentials. 

2. On the Welcome to the InstallShield Wizard for SafeNet Authentication Service Agent for 
Microsoft RDGateway window, click Next. 
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3. On the License Agreement window, read the software license agreement and to proceed, select I 
accept the terms in the license agreement option, and click Next. 

 

4. On the Agent Mode Selection screen, select the Together with RDWeb Agent radio option, and click 
Next.  
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5. On the Logon Information window, enter the credentials of a user with administrator privileges or a 
user who is a member of the Domain Admin group, and click Next.   

 

6. On the Custom Setup window, clear the components that you do not want to install, and click Next.  

a. For RD Gateway, RDGatewayMonitor and RDGPlugins features need to be installed.  

b. For RD Web, only RDWeb feature needs to be installed. 
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7. On the Ready to Install the Program window, click Install to begin the installation. 

 

8. When the installation is completed, the InstallShield Wizard Completed window is displayed. Click 
Finish to exit the installation wizard. 

 

Uninstalling the Agent 

To uninstall the SafeNet Agent for RD Gateway, perform the steps: 

1. Navigate to Start > Control Panel > Programs and Features. 

2. Select the SafeNet Agent for RD Gateway program. 

3. Click Uninstall. 
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Upgrading the Agent 

The SafeNet Agent for RD Gateway 2.0.4 of the type, Together with RDWeb supports upgrade from 

version 2.0.0 (and above). 

NOTE: Upgrade from earlier versions (v1.0, v1.1.0 and v1.1.1) is not supported.  
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CHAPTER 3: Configuration 

Enable IE mode in Edge browser 

Perform the following steps to enable Internet Explorer (IE) mode on Microsoft Edge:  

1. Open the Microsoft Edge browser. 

2. Click Options in the top-right corner of the Edge browser and select Settings. 
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3. In the left pane, under Settings, click Default browser. 

 

4. Select Allow from the Allow sites to be reloaded in Internet Explorer mode dropdown.  

 

  



 
Configuration 

 
 

SafeNet Agent for Remote Desktop Gateway v2.0.4: Installation and Configuration Guide 
007-000361-001, Rev. E, May 2022, Copyright © 2022 Thales Group. All rights reserved. 

21 

 

5. You will be prompted to restart the browser. Click Restart. 

 

Alternatively, you can restart the Edge browser. 

6. Click Add next to Internet Explorer mode pages. 

 

Add a page pop-up window will be displayed. 
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7. In the Enter a URL field, enter the RDWeb URL, for example, https://<hostname>/RDWeb. Click Add. 

 

The URL will be added to the Page list. 

 

Certificates 

The following types of certificates are required:  

 SHA256 signed certificate used for gateway access token signing with a private key — To be 

installed at Local Computer > Personal on RD Web Server.  

For details on creating certificates for gateway access tokens, refer Appendix C.  

 General purpose SHA1/SHA256 signed certificate, which is capable of digital signing — To be 

installed at Local Computer > Personal on RD Web. The purpose of this certificate is to identify the 

publisher of the RDP file to the user. It is recommended that the certificate is either generated from a 

trusted enterprise Certificate Authority (CA) or from any of the commercial certificate authorities. This 

certificate type (SHA1 or SHA256) should be the same as the one used for your default RD Web setup. 

It comes with the default RD Web install and helps in identification of the entity, which is distributing the 

RDP file, in this case, the enterprise itself.  
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NOTE: If RD Web and RD Gateway are deployed on separate machines, create the 

SHA256 certificate on the RD Web machine, and then export it without a private key to 

the RD Gateway machine. The RD Web needs a certificate with the private key, 

whereas RD Gateway needs only the public key. 

Configuring RDG_CAP_AllUsers Network Policy 

1. Open the Network Policy Server application. 

2. In the left pane, click NPS > Policies > Network Policies. 

 

3. In the right pane, double-click RDG_CAP_AllUsers. 
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4. On the RDG_CAP_AllUsers Properties window, on the Conditions tab, select the Calling 
Station ID condition, and then click Remove. 

 

5. Click OK. 

6. Restart the NPS service. 

Updating RD Gateway Configuration with Certificate Info 

1. On the computer where you have installed the RD Gateway component of the agent, search for the RD 
Gateway Certificate Configuration application, and click it.  

 

NOTE: If you have not logged into the system as an administrator, run the RD Gateway 

Certificate Configuration application as an administrator. 
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2. On the SAS RDG Update Configuration for Cert window, perform the following steps: 

a. Select the For Gateway option. 

b. Click Browse and select the following file:  
<SystemDrive>\RDGPlugins\RD GatewayTokenVerification.dll.config 

NOTE: SystemDrive is a special system-wide environment variable found on Windows 

NT and its derivatives. Its value is the drive upon which the system directory was 

placed. In most of the cases, "C:" is the value of this variable. 

c. Click Select Certificate. 

 

3. On the Windows Security window, select the SHA256 certificate intended for the gateway access 
token signing, and click OK. 
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4. Click OK. 

 

Updating RD Web Configuration with Certificate Info 

1. On the computer where you have installed the RD Web component of the agent, search for the RD 
Web Certificate Configuration application, and click it.  

 

NOTE: If you have not logged into the system as an administrator, run the RD Gateway 

Certificate Configuration application as an administrator. 

2. On the SAS RDG Update Configuration for Cert window, perform the following steps: 

a. Select the For RD Web option. 

b. Click Browse and select the following file:  
<SystemDrive>\Windows\Web\RD Web\Pages\Web.config 

c. Click Select Certificate. 
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3. On the Windows Security window, select the SHA256 certificate intended for the gateway access 
token signing, and click OK. 

4. On the SAS RDG Update Configuration for Cert window, perform the following steps: 

a. Select the For RDP File option. 

b. Click Browse and select the following file:  
<SystemDrive>\Windows\Web\RD Web\Pages\Web.config 

c. Click Select Certificate. 

 

5. On the Windows Security window, select the SHA1/SHA256 certificate intended for digitally signing 
the RDP file, and click OK.  

6. Click OK. 

  

Configuring RD Web Parameters 

1. Open the web.config file available at the following path:  
<SystemDrive>\windows\web\RD Web\pages 

2. Edit the following keys with an appropriate value, if required:  

Key with no value Description 

<add key="RDPSignPath" value=""/> Path for the RDPSign utility. By default, the RDPSign 
utility is available in the system32 folder. 

<add key="RDPSignCertHashCode" value=""/> SHA1/SHA256 certificate hash code used for RDPSign. 
This is updated when you run the RD Gateway Agent 
Select Certificate Tool. 
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Key with no value Description 

<add key="RDPSignAlgo" value=""/> Signature Algorithm used for RDPSign. This is updated 
when you run the RD Web Agent Select Certificate Tool. 

<add key="RDPTokenTimeout" value=""/> RDP file validity, in minutes. 

<add key="CertThumbPrint" value=""/> SHA256 certificate for RD gateway access token hash 
creation. This is updated when you run the RD Gateway 
Agent Select Certificate Tool. 

<add key="DefaultTSGateway" value=""/> The hostname of the default Terminal Server Gateway. 

<add 
key="PublicModeSessionTimeoutInMinutes" 
value="" /> 

The minutes after which the session will timeout, if This 
is a public or shared computer is selected as a 
security option on the gateway authentication window. 

<add 
key="PrivateModeSessionTimeoutInMiniutes" 
value="" /> 

The minutes after which the session will timeout, if This 
is a private computer is selected as a security option 
on the gateway authentication window. 

 

Example of RD Web parameters in the web.config file: 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

<configuration> 

. 

. 

<appSettings> 

<add key="RDPSignPath" value="c:\windows\system32" /> 

<add key="RDPSignCertHashCode" 

value="6356cd93eb124ac48bc881a5089c4608702205d5"/> 

<add key="RDPSignAlgo" value="sha256RSA"/> 

<add key="RDPTokenTimeout" value="60" /> 

<add key="CertThumbPrint" 

value="52c6726c657c15c2a00ea3f4cfd1e89f3785"/> 

<add key="RDPFilePath" value="" /> 

<add key="DefaultTSGateway" value="Gateway.agent.com"/> 

<add key="PublicModeSessionTimeoutInMinutes" value="20" 

/> 

<add key="PrivateModeSessionTimeoutInMiniutes" 

value="240" /> 

</appSettings> 

. 

. 

<configuration> 
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3. Save and close the web.config file. 

Configuring RD Gateway Plugin Parameters 

1. Open the RD GatewayTokenVerification.config file available at the following path: 
<SystemDrive>\RDGPlugins 

2. Edit the following keys with an appropriate value, if required: 

Key with no value Description 

<add key="CertThumbPrint" value=""/> SHA256 certificate for RD gateway access token hash 
validation. This is updated when you run the RD Gateway 
Agent Select Certificate Tool. 

<add key="MonitorService" value=" "/> Name of the Gateway Monitor Service to communicate 
with. 

<add key="TokenReplay" value=""/> Enable or disable gateway access token reuse. 

To reuse gateway access token, set the value to false. 
Otherwise, set the value to true.  

By default, the value is set to false. 

 

Example of RD Gateway parameters in the RD GatewayTokenVerification.config file:  

 

 

 

 

 

 

 

 

 

 

 

 

 

3. Save and close the RD GatewayTokenVerification.config file. 

4. Restart the RD Gateway service. 

<configuration> 

. 

. 

<appSettings> 

<add key="CertThumbPrint" 

value="52C6726c657c15c2a082d30ea3f4cfd1e89f3785"/> 

<add key="MonitorService" value="SASRDGMonitor"/> 

<add key="TokenReplay" value="true"/> 

</appSettings> 

. 

. 

<configuration> 
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Configuring RD Gateway Monitor Parameters 

1. Open the RD GatewayMonitorservice.exe.config file available at the following path:  
<SystemDrive>\RD GatewayMonitor 

2. Edit the following keys with an appropriate value, if required: 

Key with no value Description 

<add key="RDPPath" value=""/> Path for reading authenticated and cancelled gateway access token 
queue. 

<add key="MonitorInterval" 
value=""/> 

Interval, in seconds, for monitoring active connections. 

<add key="Debug" value=" "/> Enable or disable additional logging. 

 

Example of RD Gateway Monitor parameters in the RD GatewayMonitorservice.exe.config file: 

 

 

 

 

 

 

 

 

 

 

 

3. Save and close the RD GatewayMonitorservice.exe.config file. 

4. Restart the SAS RD Gateway Monitor service. 

Blocking Direct Access to Remote Machines 

If a client machine can directly access the remote machine (session host), the SafeNet Agent for RD 

Gateway Agent will not work. To block direct access to the remote machine, complete the following steps: 

1. On the remote machine, open Windows Firewall with Advanced Security. 

2. In the left pane, click Inbound Rules. 

<configuration> 

. 

. 

<appSettings> 

<add key="RDPPath" value="c:\rdgplugins\rdp"/> 

<add key="MonitorInterval" value="5"/> 

</appSettings> 

. 

. 

<configuration> 
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3. In the middle pane, search for Remote Desktop Services - Shadow (TCP-In) and double-click it. 

4. On the Remote Desktop Services - Shadow (TCP-In) Properties window, click the Scope tab. 

5. Under Remote IP address, select These IP addresses. 

6. Click Add and then add IP address of the RD Gateway server. 
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7. Click OK. 

 

8. Repeat steps 3 to 7 for Remote Desktop Services – User Mode (TCP-In) and Remote Desktop 
Services – User Mode (UDP-In). 

Now, connection to the remote machine can be established only through the RD Gateway server. 

Performing Web Browser Settings 

The web browser settings to be completed on the client machine are given below. 

1. In the Internet Explorer web browser, click Tools > Internet Options. 
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2. Click the Security tab. Select the Trusted sites zone, and click Sites. 

 

Note: Please make sure that the Enable Protected Mode… checkbox is clear. 

3. On the Trusted sites window, perform these steps: 

a. In the Add this website to the zone field, enter the URL of the website that you want to add as a 
trusted website. 

b. Click Add. 

c. Click Close. 
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4. On the Security tab, click Custom level. 

5. Under ActiveX controls and plug-ins, configure settings as described below. Then, click OK. 

Download signed ActiveX controls Disable 

Download unsigned ActiveX controls Disable 

Initialize and script ActiveX controls not marked as safe for scripting Enable 

 

Allow Scriptlets Prompt 

Automatic prompting for ActiveX controls Enable 

Only allow approved domains to use ActiveX without prompt Enable 

Run ActiveX controls and plug-ins Prompt 

Run antimalware software on ActiveX controls Enable 

Script ActiveX controls marked safe for scripting* Prompt 
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RD Gateway ActiveX Control 

Installing RD Gateway ActiveX Control Silently 

To install the RD Gateway Active X control in silent mode, run the following command as an administrator: 

ActiveXforSafenetAuthenticationServiceAgent.exe /s /v/qn 

Uninstalling RD Gateway ActiveX Control Silently 

To uninstall the RD Gateway Active X control in silent mode, run the following command as an 

administrator: 

ActiveXforSafenetAuthenticationServiceAgent.exe /x /s /v/qn 

Installing RD Gateway ActiveX Control via Installer 

Run the ActiveX for Safenet Authentication Service Agent installer. If you have logged into the system 

as an administrator, the installation process will run successfully. 

1. On the Welcome window, click Next.  
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2. On the License Agreement window, select I accept the terms in the license agreement, and then 
click Next. 

 

3. On the Ready to Install the Program window, click Install to begin the installation. 
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4. When the process completes, the InstallShield Wizard Completed window opens.  
Click Finish to exit the installation wizard. 
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APPENDIX A: Troubleshooting 

Exporting Logs for Troubleshooting 

To export logs on RD Gateway, run the following commands on Powershell: 

(Get-Service "RD GatewayMonitorService").ExecuteCommand(129) 

get-eventlog -newest 1000 -Logname "Application" -Source "RD GatewayMonitorSource" 

-ErrorAction SilentlyContinue | Select TimeWritten, Message | Export-csv 

.\desktop\RDGateway.csv 

copy c:\RDGPlugins\log.txt and save 

 

To export logs on RD Web, run the following command on Powershell: 

get-eventlog -newest 1000 -Logname "Application" -Source "RD WebAccess" -

ErrorAction SilentlyContinue | Select TimeWritten, Message | Export-csv 

.\desktop\RDWeb.csv 

Creating Installation Log 

If you require that the installation log is created, run the installer from the command prompt using the following 

command: RD Gateway.exe /V"/L* setup.log" 

Error Handling 

Permissions and NetBIOS Error 

If you encounter the ‘Permissions and NetBIOS’ error while launching the RDP file, review the Resource 

Authorization Policy (RAP) and ensure that it is in the right order. 
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1923 Error 

When you have uninstalled the agent and are trying to install it again, you may encounter the 1923 error: 

 

The uninstallation process of the SafeNet Agent for RD Gateway may not remove the RD Gateway Monitor 

service in several conditions, and change the state of the service to disabled and mark it for deletion.  

In this case, log off or restart the system, and then check if the service was removed. 

Certificate Error 

While connecting to the protected remote computer, you may encounter the error shown in the screen below. 

This error is shown because the certificate used is not a proper certificate. Replace your certificate with a proper 

certificate, and then try again. 
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Installation Error 

During a few instances, the RD Gateway service (tsgateway) does not stop automatically on installation or 

uninstallation. In these cases, the user needs to manually stop the service. 

To stop the RD Gateway service, perform the following steps: 

1. Open the Task Manager. 

2. On the Service tab, search for the tsgateway service, and note down its process ID (PID). 

3. On the Details tab, search for the process ID. 

4. Select the process PID, and click End Task. 

To verify the status of the RD Gateway service, perform the following steps: 

1. Go to Services Console. 

2. Search for the RD Gateway service. The status should be Stopped. 

If the user continues with the installation or uninstallation without manually stopping the RD Gateway service, 

the following error (Error 1722) will appear: 

 

Hostname Fetching Error 

On the client machine, while connecting to a remote machine using the agent, you may encounter the following 

error after the IIS authentication page: 

 

To solve the issue, follow the steps: 

1. Perform the Active X settings as illustrated in Performing Web Browser Settings on page 32. 

2. In Internet Explorer, in the Tools menu, ensure that ActiveX Filtering is not checked. 
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Hostname Unavailability Error 

On the Work Resources window, when you click on Connect to a Remote PC, you may see the following 

error message: 

 

To resolve this issue, refer the Configuring RD Web Parameters section, and set the following parameter:  

<add key="DefaultTSGateway" value=""/> 
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TS Gateway Service Restart Issues 

If Remote Desktop Gateway installer reports errors while installation or uninstallation, the RD Gateway service 

(tsgateway) should be kept in Stopped state for subsequent attempts for installation or uninstallation. 

The following installation command should be run from the command line: 

RD Gateway.exe /V"/L* setup.log" 

The setup.log file created should be shared with the support team for troubleshooting. 

Updating RD Connection Protocol 

To update the RD connection protocol to 8.1 (on Windows 7), install the following packages: 

 2830477 

 2574819 

Disconnecting Established Connection on RD Web 

To fully disconnect an established connection on the client machine, make sure that the remote connection icon 

at the task bar is not visible. If it is visible, right-click on the icon and select Disconnect all connections. 

 

Hostname Resolution 

The hostname of the RD Gateway server should be resolvable at the client machine. Ideally, the resolution is 

done by the DNS server configured on the client machine. Also, in DNS of the corporate network, the entry for 

the RD Gateway server should already be done. However, if not yet done, it needs to be manually configured in 

the hosts file of the client machine. 

This also applies for regular install of the RD Web and the RD Gateway (without the Agent). 

https://support.microsoft.com/en-us/kb/2830477
https://support.microsoft.com/en-us/kb/2574819
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Publisher Identity Issues 

If a user is prompted with the following publisher identity not recognized screen:  

 

The user must perform the following steps:  

1. Check if the key RDPSignAlgo has correct values at: 
<SystemDrive>\windows\web\RDWeb\pages\Web.Config 

2. If the values of the RDPSignAlgo parameter is not in accordance with the certificate algorithm of the 
default RD Web setup, upload the correct certificate in the configuration update section. 

3. Once all the values are correct,  the user will be prompted with the following screen:  
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APPENDIX B: Error Codes and Messages 

The following error message appears when the RD Gateway Service is in the Stopping or Stopped state: 

 

If the RD Gateway service is in the Stopped state, restart the service. 

If the RD Gateway service is in the Stopping state, kill the service and start again. Check if the service is in the 
Running state and try to connect again. 

The following error message appears when the user is on the IIS Resource page and IIS Stops working: 

 

Start IIS. Check if the Remote Desktop Gateway service is up (start if it is stopped) and try to connect again. 
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The following error message appears when: 

 An RDP file is downloaded by a user on a machine, and that file is used with the same user credentials 

on a different machine. 

 Timeout for a token occurs. 

 

The following error message appears when the Session Host is not reachable. Either the machine is switched off, 

or some network issue exists: 

 

Check if the session host machine could be successfully pinged. 

The following error message appears when a parallel session is tried to establish with a session host, using the 
same credentials. The last connection remains established. The prior connection shows this error message and 
the RD connection terminates. 
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APPENDIX C: Creating Certificates for 
Gateway Access Tokens 

Creating Certificates Using makecert Command 

If you want to generate a certificate on your own using the Command Line Interface (CLI), use the following 

command: 

makecert [basic | extended options] [outputCertificateFile] 

Example of the makecert command: 

makecert -pe -n "CN=Gateway Server Cert" -b 08/17/2015 -e 08/17/2025 -ss My -sr 

LocalMachine -sky exchange -sy 24 -a sha256 

NOTE: MakeCert is available as part of the Windows SDK, which you can download from 

here. 

 

The table below contains the list of options used in the above command:  

Command Option Description 

-pe Mark generated private key as exportable 

-ss <store> Subject's certificate store name that stores the output certificate 

-sr <location> Subject's certificate store location 

<CurrentUser | LocalMachine>. Default value used is CurrentUser. 

-n <X509name> Certificate subject X500 name (for example, CN=Fred Dews) 

-a <algorithm> The signature's digest algorithm, which should be SHA256. 

-sy <type> Subject's CryptoAPI provider's type 

-sky <keytype> Specifies the subject's key type, which must be a signature, an exchange, or an integer 
that represents a provider type. Here, pass 1 for an exchange key. 

-b <mm/dd/yyyy> Start of the validity period; default value used is now 

-e <mm/dd/yyyy> End of validity period; defaults value used is 2039 

  

http://go.microsoft.com/fwlink/p/?linkid=84091
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Creating Certificates Using Enterprise Certificate Authority 

Ensure that the Microsoft Enterprise Certificate Authority is set up. Also, while configuring AD CS, ensure that 

the SHA256 algorithm is specified as a cryptographic provider for signing certificates. 

 

NOTE: If you have RD Gateway and RD Web installed on separate machines, perform the 

steps: 

1. On the RD Web machine, create a certificate using a certificate template. 

2. On the RD Web machine, export this new certificate (without a private key). 

3. On the RD Gateway machine, import this certificate. 

The subsections below discuss creating a certificate template and creating a certificate 

using a template. 

Creating Certificate Template for SHA256 Certificates 

1. Search for the Certificate Authority application, and click it.  
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2. On the Certification Authority Management Console window, in the left pane, right-click Certificate 
Templates, and then select Manage. 

 

3. Scroll down to the Web Server certificate template, right-click it, and select Duplicate Template. 
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4. On the Properties of New Template window, on the General tab, enter the Template display name and 
Template name. 

 

5. On the Compatibility tab, specify the applicable compatibility settings. 
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6. On the Compatibility tab, specify the applicable compatibility settings. 

 

7. On the Request Handling tab, select Allow private key to be exported if the certificate is to be deployed 
to multiple servers. 
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8. On the Cryptography tab, select Requests must use one of the following providers. Then, in the list of 
providers, select only Microsoft Enhanced RSA and AES Cryptographic Provider. 

 

9. On the Security tab, add SYSTEM as a user. Then, provide Enroll permission to the SYSTEM user. 
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10. On the Subject Name tab, select Build from this Active Directory information. 

 

11. On the Extensions tab, select the Application Policies extension, and then click Edit. 
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12. On the Edit Application Policies Extension window, add Code Signing as an application policy, and then 
click OK. 

 

13. On the Extensions tab, under Description of Application Policies, Code Signing is added. Remove all 
other application policies. Then, click OK. 
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14. The newly created template, SHA256 Certificate - SAS Agent for RD Gateway, is now available in the list 
of certificate templates. 

 

15. On the Certification Authority Management Console window, in the left pane, expand RD WEB, right-
click Certificate Templates, and then click New > Certificate Template to Issue.  
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16. On the Enable Certificate Templates window, select your certificate template, and click OK.  

 

17. The certificate template you selected is added to the list certificate templates. Close this window.  
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Creating SHA256 Certificate Using Certificate Template 

1. Open the Microsoft Management Console. 

2. From the File menu, select Add/Remove Snap-in. 

 

3. On the Add or Remove Snap-ins window, in the Available snap-ins list, select Certificates, and click 
Add >. 

 

4. On the Certificates snap-in window, select Computer account, and then click Next.  
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5. On the Select Computer window, click Finish. 

 

6. On the Console Root window, expand Console Root > Certificates > Personal. Then, right-click 
Certificates and click All Tasks > Request New Certificate. 
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7. On the Certificate Enrollment window, select your certificate template, and click Enroll. 

 

 

 


