Your suggested change has been received. Thank you.

close

Suggest A Change

https://thales.na.market.dpondemand.io/docs/dpod/services/kmo….

back

Release Notes

Release Notes - pdbctl 1.5.1

search

Release Notes - pdbctl 1.5.1

Product Description

The pdbctl utility is a stand-alone utility that performs data migrations for CDP clients using the CipherTrust Manager.

Release Description

This release includes bug fixes.

Resolved Issues

Issue Severity Synopsis
PDB-4059 M Unable to add a database connection if the database user contains & in the password.
PDB-3913 H During migration, the following error is returned:
Insert trigger name is too long

Known Issues

Issue Severity Synopsis
PDB-4090 M During data migration/recreation of views and triggers, following error message is returned:
New table name is too long or Intermediate view name is too long.
Workaround
When migrating/recreating views and triggers with -n and -i flags, specify the new table name and IDV view name of length less than 30 characters.
Table name and IDV view name greater than 30 characters are not supported with database used.
PDB-3488 L Decryption fails if the value of ING_ROW_ID exceeds the range of int data type.
Workaround
Run the following script as table owner.
DECLARE
CURSOR c_rows is
SELECT ROWID FROM <TABLE_NAME>_new;
val NUMBER :=1;
BEGIN
FOR n IN c_rows LOOP
UPDATE <TABLE_NAME>_NEW SET ING_ROW_ID=val where ROWID=n.ROWID;
val:=val+1;
END LOOP;
COMMIT;
END;
/
PDB-3739 H XMLTYPE does not work with the pdbctl utility.

Limitations

  • Error replacement value is not supported.

  • Migration of tables with identity columns are not supported.

  • Centralized management of multiple databases is not supported.

  • No graphic user interface, only command line interface is supported.

  • Java 1.8.0_252 or higher is mandatory for utility to run.

  • Oracle database's Java version should be 1.6.0_121 or higher for SSL connection.

  • After migration, instead of returning the INSERT/UPDATE operation disallowed error, the insert and update operations get surpassed on virtual columns; however, the behavior remains the same, the values in the virtual columns are based on the original default value expression.

Compatibility

This section documents known compatibility topics to be considered before deploying the pdbctl utility.

Key Manager

The pdbctl utility can be used with CipherTrust Manager 1.8.0 and higher versions.

CDP Clients

CDP Client Minimum Supported Version
CDP for Oracle 8.10.0 or higher versions
CDP for MS SQL 8.10.0 or higher versions
CDP for DB2 8.8.0 or higher versions